Degraded performance for MitID
Incident Report for Monthio Status
Resolved
Posted Oct 05, 2022 - 20:23 CEST
Monitoring
MitID is currently experiencing degraded performance, and applicants can experience issues when using MitID.

We will set up a banner in the application flow advising applicants to finish their application later, should they have issues using MitID.
Posted Oct 05, 2022 - 18:14 CEST