Intercom (chat) is not working

Incident Report for Monthio

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:08 CEST

Investigating

ENGLISH
It is currently not possible to chat with our support.

Please contact us via support@monthio.com.

We apologize for the inconvenience, and are working on fixing the issue as fast as possible.


DANISH
Det er i øjeblikket ikke muligt at chatte med vores support.

Kontakt os venligst via support@monthio.com

Vi beklager ulejligheden og arbejder på at løse problemet så hurtigt som muligt.
Posted Oct 20, 2025 - 12:28 CEST
This incident affected: Support.