Nordea Outage in Finland [RESOLVED]

Incident Report for Monthio

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 15:04 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 14:44 CEST

Update

We are continuing to investigate this issue.
Posted Sep 08, 2025 - 12:48 CEST

Investigating

ENGLISH
Nordea has, since 10:40 yesterday, had degraded performance, and we are now seeing a complete outage. Applicants will experience issues trying to connect to Nordea in the application flow.

We recommend that applicants with accounts in Nordea try going through the application later, should they experience issues. We will advise them to do so via a banner in the flow.
Posted Sep 05, 2025 - 12:42 CEST
This incident affected: Finland (Bank integrations).